¿Como volver a otra version (anterior) de WordPress?

jQuery error

Después de que ha salido el WordPress 5.6 se han cambiado muchas cosas.

En una de las webs no era posible de actualizar toda la funcionalidad y actualizar todo los plugins y entonces el cliente ha decidido de reinstalar el WordPress a una version anterior (5.5.3), cuando funcionaba todo.

IMPORTANTE! Que han actualizado uso de jQuery y entonces ha aparecido muchos errores donde muchas funciones deprecados.

Ejemplo:

wp-content/plugins/wpml-translation-management/res/js/scripts.js:118:20): jQuery.browser is deprecated
/wp-content/plugins/wpml-translation-management/res/js/scripts.js:118:38): jQuery.browser is deprecated
wp-content/themes/houzez/js/admin/init.js:152:20): jQuery.fn.load() is deprecated

¿Como volver a version anterior de WordPress?

Para ello, es necesario instalar el plugin Wp downgrade

Después, buscamos números correctos aqí: https://wordpress.org/download/releases/

Indicamos la version correcta y damos a reinstalar la version anterior en la parte de update

wp-admin/update-core.php

Presionando el botón «Reinstall»

¿Como actualizar entonces?

Para encontrar errores de jQuery hay que instalar este plugin Enable jQuery Migrate Helper
Así, antes de actualizar, hay que corregir estos errores… en mayoría de casos solo necesites actualizar los plugins y todo volverá a funcionar.

Pero si necesites comprobar antes de que actualizes a WordPress 5.6 hay que mirar y correjor errores que aparezca en informe del jQuery Migrate Helper

Saludos!